русс | укр

Языки программирования

ПаскальСиАссемблерJavaMatlabPhpHtmlJavaScriptCSSC#DelphiТурбо Пролог

Компьютерные сетиСистемное программное обеспечениеИнформационные технологииПрограммирование

Все о программировании


Linux Unix Алгоритмические языки Аналоговые и гибридные вычислительные устройства Архитектура микроконтроллеров Введение в разработку распределенных информационных систем Введение в численные методы Дискретная математика Информационное обслуживание пользователей Информация и моделирование в управлении производством Компьютерная графика Математическое и компьютерное моделирование Моделирование Нейрокомпьютеры Проектирование программ диагностики компьютерных систем и сетей Проектирование системных программ Системы счисления Теория статистики Теория оптимизации Уроки AutoCAD 3D Уроки базы данных Access Уроки Orcad Цифровые автоматы Шпаргалки по компьютеру Шпаргалки по программированию Экспертные системы Элементы теории информации

Работа со служебными типами данных и объектами компоненты "Бухгалтерский учет"

1. Работа с бухгалтерскими счетами

Счет – это агрегатный тип данных для доступа к объектам данных – бухгалтерским счетам. Бухгалтерские счета используются для идентификации разрезов синтетического учета наличия и движения средств.

В конфигурации может быть несколько планов счетов. Объект типа «Счет» может относиться к конкретному плану счетов или быть неопределенного вида, т.е. принимать значения различных планов счетов.

Структура данных объектов типа «Счет» задается в конфигураторе в разделе «Планы счетов» и является одинаковой для всех планов счетов.

У счета определены следующие атрибуты:  

  • «Код» – в общем случае представляет собой символьную строку вида <Код счета>.<Код субсчета>.<Код субсчета> и т.д.
  • «Наименование» – наименование счета.
  • «Валютный» – признак ведения валютного учета.
  • «Количественный» – признак ведения количественного учета.
  • «Забалансовый» – признак того, что счет является забалансовым.
  • «Активный» – принимает три значения: 1 – активный, 2 – пассивный, 3 – активно-пассивный.

Наиболее важные функции: «КоличествоСубконто()» – возвращает количество субконто у текущего счета, «ВидСубконто()» – устанавливает/возвращает вид субконто по порядковому номеру.

 

2. Работа с операциями и проводками

Для отражения в бухгалтерском учете информации о движении средств используются «Операции» и «Проводки».

  • Объект типа «Операция» используется для формирования и анализа проводок, формируемых документом. Для этого у агрегатного объекта «Документ» существует атрибут «Операция», который обеспечивает доступ к операции данного документа. Чтобы документ формировал операцию необходимо, чтобы в документе стоял флажок  «Бухгалтерский учет».
  • Объект «Операция» также доступен непосредственно в контекстах формы «операции», формы «журнала операций» и формы «журнала проводок».
  • Объект «Операция» используется для перебора существующих операций и проводок при формировании отчетов и других выборок.  В этом случае объект создается при помощи вызова функции СоздатьОбъект(«Операция»).

Операция имеет следующие атрибуты:
«ДатаОперации», «Содержание», «СуммаОперации», «Документ» – документ, которому принадлжит  операция, «Сумма» – сумма текущей проводки операции, «Валюта» – валюта текущей проводки, «ВалСумма» – валютная сумма текущей проводки, «Количество» – количество текущей проводки, «Дебет» – обращение к дебету проводки, «Кредит» – обращение к кредиту проводки. Объекты «Дебет» и «Кредит» имеют следующие атрибуты: «Счет», «Субконто» 

Пример:

Опер=СоздатьОбъект(«Операция»);

Опер.ВыбратьОперации(Дата1,Дата2);

Пока Опер.ПолучитьОперацию()=1 Цикл

Опер.ВыбратьПроводки();

Пока Опер.ПолучитьПроводку()=1 Цикл
Если Опер.Дебет.Счет=СчетПоКоду(«60.1») Тогда
Сообщить(«Субконто »+Опер.Дебет.Организация);
КонецЕсли;
КонецЦикла;

КонецЦикла;

Чтобы проводки не попадали в бухгалтерские итоги, используется функция «ОтключитьПроводки()».

 

3. Работа с корректными проводками

Для работы с корректными проводками в системе используется специальный тип данных «КорректныеПроводки». Объект создается функцией «СоздатьОбъект». Атрибуты: «Комментарий», «СчетДт», «СчетКт».

Для добавления новой корректной проводки используется функция «Новая()»;

Пример

КП=СоздатьОбъект(«КорректныеПроводки»);

КП.Новая();

КП.Комментарий= «НДС с комиссионного вознаграждения»;

КП.СчетДт=СчетПоКоду(«46.28»);
КП.СчетКт=СчетПоКоду(«68.2»);

КП.Записать();

Просмотров: 18459

Вернуться воглавление


Карта сайта Карта сайта укр


Уроки php mysql Программирование

Онлайн система счисления Калькулятор онлайн обычный Инженерный калькулятор онлайн Замена русских букв на английские для вебмастеров Замена русских букв на английские

Аппаратное и программное обеспечение Графика и компьютерная сфера Интегрированная геоинформационная система Интернет Компьютер Комплектующие компьютера Лекции Методы и средства измерений неэлектрических величин Обслуживание компьютерных и периферийных устройств Операционные системы Параллельное программирование Проектирование электронных средств Периферийные устройства Полезные ресурсы для программистов Программы для программистов Статьи для программистов Cтруктура и организация данных


 


Полезен материал? Поделись:

Не нашли то, что искали? Google вам в помощь!

 
 

© life-prog.ru При использовании материалов прямая ссылка на сайт обязательна.